How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Kevin C. Your Own Question
Kevin C.
Kevin C., Subaru Master Tech.
Category: Subaru
Satisfied Customers: 1727
Experience:  34 years of Subaru service experience, ASE Master Technician.
49406277
Type Your Subaru Question Here...
Kevin C. is online now
A new question is answered every 9 seconds

I have a 2004 Subaru outback H6 with auto climate control.

Customer Question

I have a 2004 Subaru outback H6 with auto climate control. The blower motor wont come on. I replaced the head unit resistor and relay. The blower test is ok. When you turn on the head unit there is no existence of ground at the relay violet wire thus relay wont energize. When I give it ground it energizes but no existence of ground at the blower motor. Im stumped! all circuit parts are new including ECM.
Submitted: 1 year ago.
Category: Subaru
Expert:  Jeromy Madison replied 1 year ago.

Hello, I have looked at the the wiring diagram.

Are you able to perform a few continuity test?

Customer: replied 1 year ago.
Customer: replied 1 year ago.
I attached the wiring diagram
Expert:  Jeromy Madison replied 1 year ago.

Ok. I need you to check continuity between a couple of connectors.

Can you get to the connector at the a/c control module?

Check continuity between the black/yellow wire that is supposed to be in pin #11 to the connector of the blower motor resistor that is black/yellow pin #2.

Expert:  Jeromy Madison replied 1 year ago.

Then check between the black/yellow wire #2 at the resistor to the black/yellow wire #2 at the blower motor.

Customer: replied 1 year ago.
I am checking the car is at the shop. I am at home. I called my other mechanic to do these tests at the shop for me. Bare with me.
Customer: replied 1 year ago.
I am pretty sure I did these tests but just checking again./ I told him to do both for me #11 and #14 BY and VY
Customer: replied 1 year ago.
Does the pressure switch have anything to do with the blower motor? As it is low and a/c relay does not come as well.
Customer: replied 1 year ago.
I brought up pressure to make the relay come on but did not effect the problem just wondering
Customer: replied 1 year ago.
from resistor to blower motor is fine
Customer: replied 1 year ago.
just to let you know what I did. So you can conclude all other wiring is fine. I grounded VY at the relay and grounded BY at the blower and it comes on when ignition is on. But of course no speeds
Customer: replied 1 year ago.
assuming I had a bad head unit I replaced it. No change
Customer: replied 1 year ago.
Both #11 and #14 are fine
Customer: replied 1 year ago.
For such an extremely simple wiring diagram I have never been so stumped
Expert:  Jeromy Madison replied 1 year ago.

Ok. So when you turn on the system do you have ground at the ecm pin #11?