How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask tamaz Your Own Question
tamaz
tamaz, Subaru master technician
Category: Subaru
Satisfied Customers: 1203
Experience:  Subaru certified,ASE Master technician,25 years experience
70031029
Type Your Subaru Question Here...
tamaz is online now
A new question is answered every 9 seconds

My subaru is running rough/blowing black smoke sometimes/

Customer Question

my subaru is running rough/blowing black smoke sometimes/ stalling at idle/ bucking and lurching while driving.
Submitted: 1 year ago.
Category: Subaru
Expert:  tamaz replied 1 year ago.

Hi,any check engine light?

Customer: replied 1 year ago.
there is no check engine light. I have also changed spark plugs, wires, ignition coil, fuel pressure regulator, fuel filter recently. none of these made any difference.
Expert:  tamaz replied 1 year ago.

Hi,disconnect the MAF on the air cleaner to see if it runs better,this sensor judges the fuel mixture based on incoming air,it seems your running very rich so this may be the cause,thanks

Customer: replied 1 year ago.
it does run a lot better when disconnected. not perfect but at least it idles now. also way less sputtering and no more black smoke.
Expert:  tamaz replied 1 year ago.

Hi ,replacing MAF sensor is the next step here,you also may need to replace or clean the plugs because they are fouled by now,thanks

Customer: replied 1 year ago.
what about cleaning the maf?
Expert:  tamaz replied 1 year ago.

Sure,give it a shot but be careful not to touch the components they are fragile just use some induction spray cleaner and give a good cleaning and let it air dry do not use compressed air,thanks

Customer: replied 1 year ago.
i drove it around some more today. as soon as i started the car it started smoking and acting up, so i shut it off and disconnected the maf and started it again. It was lurching and sputtering and stalling all the way home with maf disconnected. the problem seems a bit eratic because i drove to work without much incident, but on the way home it was really bad. I also cleaned the maf and tried it again. seemed to run ok for a few minutes then stared to idle rough again. Also while the car was running and the maf connected i slowly pulled the air intake hose off the maf to see what would happen. as soon as it was able to draw in outside air the car started sputtering. this tells me that the maf is doing something. it sensed the decrease in air flow from pulling the intake hose off. I just want to be sure that is the problem because a new maf isn't cheap.
Expert:  tamaz replied 1 year ago.

I understand,your right it isn't cheap.

Customer: replied 1 year ago.
your verdict is still the same? replace maf?
Expert:  tamaz replied 1 year ago.

It made a difference after cleaning for a while so I would say yes that's my verdict.