How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask tamaz Your Own Question
tamaz
tamaz, Subaru master technician
Category: Subaru
Satisfied Customers: 1134
Experience:  Subaru certified,ASE Master technician,25 years experience
70031029
Type Your Subaru Question Here...
tamaz is online now
A new question is answered every 9 seconds

I have a 2008 Subaru Forester. It was running good then

Customer Question

I have a 2008 Subaru Forester.
It was running good then check engine light flashed. Took my foot off gas and light went off. Accelerated and it came back on. Motor made car shake side to side not like running out of gas. Pulled to side of road and engine died as it slowed. Would not immediately start again. Had it towed home. It would start but ran ruff and motor vibrated side to side. Try to take off and it died. Hooked up computer to it. 2 readings of $07E08 and $07E09. Cleaned air flow valve(I think that is what it's called). It ran pretty good for several test drives then would die out if you slowed or stopped.
Any suggestions? I would take it to the dealer if I could afford it.
Submitted: 1 year ago.
Category: Subaru
Expert:  tamaz replied 1 year ago.

Hi the check engine light flashing means engine was misfiring, the codes you supplied are Lamda codes so I'm not sure their meaning.I believe the ignition system should be checked first.The best way to find ignition system failures is with a spray bottle of water ,spray the ignition coil and wires to see if you can find sparks arcing from these components,if nothing shows up close visual inspection of the coil ,spark plugs and wires will be necessary.During the time of failure was it raining or damp outside?

Customer: replied 1 year ago.
No rain nor fog. Just did this out of the blue. No trouble starting it now. Just keeping it running. It's almost like it sputters. Strong sulphur smell from tail pipe.
Expert:  tamaz replied 1 year ago.
Check the ignition system like we discussed,that sulfur smell may mean the converter is failing due to the way the car was running before,when the engine misfires raw fuel is entering the combustion chamber without being burned,let me know if you find any ignition failure with the spray bottle or inspection,thanks
Customer: replied 1 year ago.
Tried that. Didn't see anything. Changed plugs. Runs much better. Does not idle fast enough now.
Expert:  tamaz replied 1 year ago.
did you clear the codes with your reader if so the idle we need to be relearned,the process is simple run vehicle at idle with no accessories for 15 minuets,the 10 minuets with a/c on and it will be set,thanks