How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Kevin C. Your Own Question
Kevin C.
Kevin C., Subaru Master Tech.
Category: Subaru
Satisfied Customers: 1727
Experience:  34 years of Subaru service experience, ASE Master Technician.
49406277
Type Your Subaru Question Here...
Kevin C. is online now
A new question is answered every 9 seconds

Subaru Forester: . Put on after market alternator on 2006

Customer Question

Hi. Put on after market alternator on 2006 forester in June, 2014. No problems. Subaru dealer replaced head gasket, timing belt, valve, and water pump in Nov. 2014. Brake & CEL now flicker only after long drives (2 hours it starts & usually gets more frequent). On 2 occasions ABS light also flickered. Had car in shop for 8 days & they tested it under a full load, long drive, and couldn't get anything to happen. Also no error codes are being stored.
Submitted: 1 year ago.
Category: Subaru
Expert:  tamaz replied 1 year ago.
Hi,this really does sound like a voltage problem,my first instinct would be to check the alternator under the conditions mentioned,my next thought would be to check all grounds in the engine compartment most notably the ground connection at the starter bolt.
Customer: replied 1 year ago.
I appreciate your reply. I have had the car tested twice: November, 2014 and again April, 2015 under these conditions and there is no drop in output. The last garage with ACE mechanics had my car for 8 days and put on over 500 miles. The dash lights didn't flicker once. After reading tons of posts regarding subarus, it seems many people have experienced the same thing but no one has "the" answer and I feel I am on a wild goose chase. Before going on "Just Answer," I took the car to another garage and they said they couldn't help me until the lights came on solid. I then called a Subaru dealer in Milwaukee, WI, and spoke to a mechanic. After explaining the issue to him, he told me the same thing and suggested it might be a computer glitch. I'm at a loss at this point.
Expert:  tamaz replied 1 year ago.
Understood,like I said it sounds like a voltage problem,considering the fact the alternator is aftermarket it would the first thing I would suggest to change,my experiences with the aftermarket alternators have been terrible,our shop will not install them because of all the problems we have had.I must agree with the other shops about the problem becoming more consistent it sounds like they have done all the right things,in my opinion the common denominator is that alternator,but I'm still not ruling out a ground problem.
Customer: replied 1 year ago.
I have an appt. on Friday for a new alternator, then am traveling another 500 mile round trip. I will let you know if I encounter any more problems or lights flickering after that trip. Thanks for the advice.
Expert:  tamaz replied 1 year ago.
Your welcome! Good luck!