How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mike V. Your Own Question
Mike V.
Mike V., Subaru Technician
Category: Subaru
Satisfied Customers: 23844
Experience:  Certified Subaru Technician, factory trained by Subaru.
2921078
Type Your Subaru Question Here...
Mike V. is online now
A new question is answered every 9 seconds

Subaru Outback 2.5I Basic: I have a 2002 subaru outback 2.5,

This answer was rated:

I have a 2002 subaru outback 2.5, just installed a jap import engine3 and used the old intake and harnes and all my sensors off the running engine i pulled wont start and is fouling the plugs, pocket scanner said it was my cam senser and replaced twice now its saying both the cam and the crank sensor are bad both are new, timing marks are right on the money..please help
Hi there,
Check the cam sprocket and the crank sprocket and make sure they are the same as the ones off the old engine. What i see a lot is the sprockets are different and that causes the signal to be different at the ecm so the plugs and injectors don't fire at the right times.
This is where i would start with this.
Hope this helps!
Mike V. and 3 other Subaru Specialists are ready to help you