How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Chris Baxter Your Own Question

Chris Baxter
Chris Baxter, Programmer
Category: Software
Satisfied Customers: 243
Experience:  Java, iOS, VB.net, SQL, C+, C++, Obj C
68869132
Type Your Software Question Here...
Chris Baxter is online now
A new question is answered every 9 seconds

Could not install guitar pro 6 on ubuntu 16.06 (64 bit)

Customer Question

Could not install guitar pro 6 on ubuntu 16.06 (64 bit)Tried to use software manager and it stuck.
Than I run sudo dpkg -i gp6-full-linux-r11201.deb in terminal
and gotdpkg: dependency problems prevent configuration of guitarpro6:i386:
guitarpro6:i386 depends on libportaudio0.
guitarpro6:i386 depends on libportaudio2.
guitarpro6:i386 depends on gksu.
guitarpro6:i386 depends on libssl0.9.8.dpkg: error processing package guitarpro6:i386 (--install):
dependency problems - leaving unconfiguredSo I tried to resolve dependencies but
sudo apt-get install libportaudio0
returns
E: Package 'libportaudio0:i386' has no installation candidateSo, what should I do to get guitar pro 6 installed on my laptop?
Submitted: 22 days ago.
Category: Software
Expert:  Chris Baxter replied 17 days ago.

Hello!

You are missing a few packages, essentially what you do when you install with dependencies in this case is to first download the installer engines, if you did not sudo apt-get install gtk2-engines:i386 then you have missed a small step. Please see the following URL for installation instructions:

https://www.reddit.com/r/GuitarPro/comments/4vqlpc/installing_guitarpro6_on_64_bit_ubuntu_1604_and/

Customer: replied 14 days ago.
Thank you. I will check it in a few hours and comw back to you
Expert:  Chris Baxter replied 14 days ago.

Let me know if you need any further assistance! :)

Customer: replied 11 days ago.
I'm having issues with this stepSearch Ubuntu's packages for the two items listed below. Once you have them, move them to your "/lib/" folder.
[If anybody could link them, that'd be awesome]libssl.so.0.9.8 libcrypto.so.0.9.8There is nothing in search for "libssl.so" and a lot for "libssl".
Customer: replied 10 days ago.
finally I found them, did all, that was described in thread, but new error message appeared, when I tried to run gp6
>>cd /opt/GuitarPro6/ sh launcher.sh./GuitarPro: /opt/GuitarPro6/./libz.so.1: version `ZLIB_1.2.3.3' not found (required by /usr/lib/i386-linux-gnu/libxml2.so.2)And now I can't find that libz.so.1. Only libz3 or something like that are available http://packages.ubuntu.com/search?suite=yakkety&section=all&arch=any&keywords=libz&searchon=names
Expert:  Chris Baxter replied 9 days ago.

Ok, well that would be "rename lib.so.1 to lib.so.1.orig. See the following URL for more in-depth! :)

http://paoloambrosio.net/2013/11/16/installing-guitarpro6-on-ubuntu-1310-saucy-64bit.html

Customer: replied 9 days ago.
Oh. So much overhead. I've ended up with running windows version using wine. Thank you for your help
Customer: replied 2 day ago.
Is this question displayed as rated for you?