How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Bruce Wilner Your Own Question

Bruce Wilner
Bruce Wilner,
Category: Software
Satisfied Customers: 47
Experience:  principal at Network Security Labortories Inc.
Type Your Software Question Here...
Bruce Wilner is online now
A new question is answered every 9 seconds

I need some help with Adobe Captivate 9. When I make

Customer Question

I need some help with Adobe Captivate 9. When I make interactive buttons and then export it into an SWF or flash file, some of my other content does not come over on the playback e.g images. Help!
Submitted: 1 month ago.
Category: Software
Expert:  Russell H. replied 1 month ago.

Hi, thank you for contacting My name is Russell. I will do my best to provide the right answer to your question.

I suggest first of all, that you try placing the image files used, in the same directory or folder as the other content used in the interactive button. It may be that referents to other directories or folders are not being executed correctly, so that references to the image files don't 'get through' and are not displayed also. If all content that contributes to an interactive button is in the same dir/folder, then it ought not to have any problem being used/displayed/etc.

Customer: replied 1 month ago.
Hi Russell! Thank you for your answer, but what do I do if I was given the files with the images already in it? So there is no referents. These interactive buttons are supplied from software program, so I didn't customize the buttons. The problem is that everything looks fine on the captivate file, but then when I export it, pieces are missing like images (other than the buttons) and the timing is off etc.
Expert:  Russell H. replied 1 month ago.

So it is not the image buttons that are missing, but the other images?

Do those other images come from a different source than the button images?

How is the timing off?

Expert:  Russell H. replied 1 month ago.

(I regret that I am not able to offer Live Phone Call service at this time; However, your request is still open to other Experts in this category, and one of them may pick up on it at any time.)

Customer: replied 1 month ago.
The Other images are not necessarily missing they don't show up til later in the slide randomly anytime in the slide. The Button is a transparent Button not an image button. Its from the drop down on the interactions menu.
Expert:  Russell H. replied 1 month ago.

I'm not sure I can help with this case, and since another Expert may take up your Secure Remote Assistance request, I feel that I should overtly cede the case to another Expert, as well as Opt Out. I have Opted Out, opening the case, as well as its Secure Remote Assistance offer, to other Experts in this category.

Expert:  Bruce Wilner replied 1 month ago.

Hi! Did you make sure that you set all the required options and preferences on the export dialog? It is entirely non-trivial to export a project from one tool or format to another: there are however many pieces and "tentacles" that reference things way over yonder.

Expert:  Bruce Wilner replied 1 month ago.

As Russell indicated, there can always be problems with referents. In particular, if there are files referenced by the project that are not all within the same top folder, but are scattered here and there, the engine may have difficulty tracking down all the links. Not to cast aspersions, but many of these products with rich capabilities are not tested nearly as thoroughly as they should be. As a result, what users rightfully consider to be simple-minded operations turn out to have many pitfalls.

Customer: replied 1 month ago.
I no longer need assistance.
Expert:  Bruce Wilner replied 1 month ago.

Were my suggestions of help, or did you solve the problem on your own?

Customer: replied 1 month ago.
I solved myself. I just copied and pasted the information in a new project. The project had an error.
Expert:  Bruce Wilner replied 1 month ago.

Well, we can't determine that in a vacuum without seeing the project! It's best to test a project very thoroughly before trying to export it to some other representation. Thank you for contacting!