How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Rylan Sharpe Your Own Question

Rylan Sharpe
Rylan Sharpe, Computer Hardware Engineer
Category: Software
Satisfied Customers: 94
Experience:  Global IT Manager at an International Company
Type Your Software Question Here...
Rylan Sharpe is online now
A new question is answered every 9 seconds

In the attached Microsoft Visio 2007 document, I cannot

Customer Question

In the attached Microsoft Visio 2007 document, I cannot connect the two shapes using a connector. When I hover over either shape, it does not highlight the shape or display arrows for connecting to adjacent shapes. This is in Visio2007. If I open it in Visio 2016, it works fine. But I need to do this in Visio 2007.
Submitted: 2 months ago.
Category: Software
Expert:  Kevin T replied 2 months ago.

WOuld you like me to do it or would you like me to show you how?

Customer: replied 2 months ago.
I really need to learn how to do this. I just gave you an example. I have many different shapes to do this with, and a lot of them have this problem.
Customer: replied 2 months ago.
Using Visio 2007,not 2010, 2013,or 2016.
Customer: replied 2 months ago.
Expert:  Kevin T replied 2 months ago.

I can connect and show you If you like

Customer: replied 2 months ago.
That will not work. The only PC I can let you connect to runs Visio 2016, and this problem is does not occur there. I must use Bisio 2007 at work (where you may not connect).I need to know what is different about this and similar custom shapes that is preventing Visio from connecting to it. v2016 does not have an issue with these shapes, so I cannot see what they are "missing"
Expert:  Kevin T replied 2 months ago.

Would it be possible if we upgraded you?

Customer: replied 2 months ago.
Upgraded what?? My work PC??? No, no, no, no.Something is different about this and similar shapes that somehow Visio 2007 cannot attach a connector to it like it does most shapes. Upgrading Visio is NOT an option I can use. I think a property or something in the shape's definition needs to be changed, but I do not know what.Do you know Visio 2007 well enough to work this out?
Expert:  Rylan Sharpe replied 2 months ago.

Hello, I am happy to assist you with this question. I am downloading your file now to take a look.

Expert:  Rylan Sharpe replied 2 months ago.

Are you using custom stencils in your Visio file?

Customer: replied 2 months ago.
Rylan, I am using custom stencils, yes. I just figured out that, if I un-group an instance of a "compound" (my term, not MS's) stencil, Visio 2007 will allow connectors to attach to its underlying component shapes. But I should not have to do this for every shape I need to connect. There are some "compound" stencils that Visio 2007 connects to just fine. Its the ones that it doesn't (like the one in my sample) that I am having trouble with.Visio 2016 handles these problem shapes just fine, BTW.
Expert:  Rylan Sharpe replied 2 months ago.

That is very interesting. Do you mind sending me a few sample stencils that I can test with on my end?

Customer: replied 2 months ago.
Sure. Here is another sample with shapes that work correctly and others that do not.I may have uncovered something else just now. I downloaded some custom stencils from Cisco, and they had the same issue. When I tried to "un-group" one of them, it asked if it was OK to break its connection with its master. I said yes, and the shape highlighted, but remained grouped. But now connectors properly worked with it. This repeated with several other shapes in the Cisco stencil library.This could lead to an acceptable workaround, I think. This process still needs to be repeated for each instance of a shape, which is tedious. If I add the altered shape to my cus***** *****brary, then use it, those copies work fine.I still believe something else is off here. Editing the original master might work, I'll have to see. I'd like to be able to retain the links to the original master shapes for the hundreds of instances I have to deal with.
Customer: replied 2 months ago.
I got an email saying you had responded to my latest post, but I do not see any response, and the status still says "awaiting a reply"