How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Jess M. Your Own Question

Jess M.
Jess M., Computer Support Specialist
Category: Software
Satisfied Customers: 504
Experience:  Computer Software Support specialist for more that 10 years
Type Your Software Question Here...
Jess M. is online now
A new question is answered every 9 seconds

Not sure which category of computers.. Anyway. I was having

Customer Question

Not sure which category of computers.. Anyway. I was having problems with pictures and other sites freezing up and cannot click to get out of anything. So my husband supposedly got all the updates, or whatever he did. I was using Firefox, so when all was finished, the Firefox is basically a blank page. No bookmarks, no tabs, nothing. How do I get back what I had previously? I am currently using Chrome to type this
Submitted: 4 months ago.
Category: Software
Expert:  Barun replied 4 months ago.

Hi, and thank you for asking your question.

Just to clarify, does Firefox stop responding when you open it up now?

May I connect with you remotely to troubleshoot the issue now?

Please reply back using the box below; thank you.

Customer: replied 4 months ago.
no, like I said, it's a blank page. No bookmarks, no tabs. nothing. I just want back what i had before
Expert:  Barun replied 4 months ago.

Hmm, okay. May we set up a quick remote session now, so that I can check the issue here?

Expert:  Barun replied 4 months ago.

You seem to have gone offline now; since I have go off shortly as well, let me open up your question to our other experts who can assist further. Thank you.

Expert:  Cory replied 4 months ago.


I am aware of the issue. May I connect remotely and fix this?