How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Technician
Category: Small Engine
Satisfied Customers: 27155
Experience:  17 years automotive training and experience.
14928985
Type Your Small Engine Question Here...
Pete is online now
A new question is answered every 9 seconds

My deere 1600 turbo bat wing seems to lack hydraulic

Customer Question

My john deere 1600 turbo bat wing seems to lack hydraulic pressure when all three decks are engaged. When i lift either wing up the remaining two decks work just fine.
JA: Sometimes things that you think will be really complicated end up being easy to fix. The Heavy Equipment Mechanic I'm going to connect you with knows all the tricks and shortcuts.
Customer: Is the main hydraulic pump belt driven?
JA: Are you fixing this yourself? What have you tried so far?
Customer: Yes i am fixing it myself. i am trying to figure out what to check.
JA: Anything else you want the agriculture mechanic to know before I connect you?
Customer: no
Submitted: 12 days ago.
Category: Small Engine
Expert:  Pete replied 11 days ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know.

This can be due to an internal fault with the hydraulic pump itself to weak to control all 3 decks at the same time.I have seen some of the pumps fail and cause this type of fault here in the past with the pump needing replaced.I would have the pump tested to make sure there are no issues with a possible belt slipping or to see if the pump needs replaced.I suspect the pump may need replaced.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,your 5 star rating is appreciated.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete