How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 27470
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
30244710
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

I have a Generac 8KW modelgenerator. It hasnt been running

Customer Question

Hi. I have a Generac 8KW model(###) ###-####generator. It hasnt been running for a while due to a dead battery. I replaced the battery but when I hooked it up all of the red lights on the control panel flash intermittently together. If I place the switch in Auto the green Ready light lights up but the other red lights continue to flash. If I put the switch into manual mode all I hear is a loud click like a relay or solenoid but the motor does not crank. The red lights are always flashing. I have to pull the main fuse to get them to stop. Any ideas?
Submitted: 4 months ago.
Category: Small Engine
Expert:  Curtis B. replied 4 months ago.

Welcome to JUST ANSWER small engines, let me try to help you !! I don't know it all, but maybe together we can get you a satisfactory answer!

Expert:  Curtis B. replied 4 months ago.

Can you turn the engine manually? Engine is not locked? If you jump the solenoid will starter spin engine? Remove spark plugs if engine will not turn.

Customer: replied 4 months ago.
I haven't tried that yet but I will. But I don't see how that could effect the flashing light condition. The lights started flashing as soon as I hooked up the positive batt terminal, without the negative even being connected yet. It never did that before.
Expert:  Curtis B. replied 4 months ago.

Battery is not connected backward? Lights should do nothing until both cables are installed.

Customer: replied 4 months ago.
NO definitely not..I agree I thought that was weird too. Possibly the control panel electronics are grounded somehow and when I hooked up the positive terminal it got juice. Not sure but the cable lengths totally prevent the battery from being hooked up backward. The red is on the + terminal.
Expert:  Curtis B. replied 4 months ago.

Had to be something to do with the ground! Or the lights would not come on. Is this a permanent installation? Check the ground connections , is generator grounded to earth?

Customer: replied 4 months ago.
it is a permanent installation. Its dark now so I'll have to wait until the morning to check if it is grounded properly.
Expert:  Curtis B. replied 4 months ago.

oK>

Expert:  Curtis B. replied 4 months ago.

I see question is still open, please rate to close.