How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 26030
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
30244710
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

I have a Ryobi 40v lithium battery leaf blower. When the

Customer Question

I have a Ryobi 40v lithium battery leaf blower. When the battery was placed on the charger the red and green light would continuosly blink and the battery would not charge. I was told that this was normal for it to blink for the first twenty minutes. However this is not true for me. I need your help.
Submitted: 18 days ago.
Category: Small Engine
Expert:  Curtis B. replied 18 days ago.

Welcome to JUST ANSWER small engines, let me try to help you !! I don't know it all, but maybe together we can get you a satisfactory answer!

Expert:  Curtis B. replied 18 days ago.

Do you have a voltmeter to check the battery voltage? Check battery, then check the output from the charger , by plugging it to wall socket and meter leads on the charger harnes. Do not plug to battery until after testing both. Then check the battery voltage while charger is on.

Customer: replied 16 days ago.
There are 4 terminals on both the battery and charger. I don't any reading on the battery or charger. Am I doing it wrong?
Expert:  Curtis B. replied 16 days ago.

Two of the four terminal on the battery should have voltage. two will be posiitve, two will be negative. you have to find the two pair that go together . If there is no reading, is the harness connected at the battery or are they direct to the harness plug in? Should be no reason that battery voltage would not be reading.??

Expert:  Curtis B. replied 13 days ago.

I see question is still open, did you find problem?