How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Donald Your Own Question
Donald
Donald, Small Engine Technician
Category: Small Engine
Satisfied Customers: 1848
Experience:  I have 25+ years of experience repairing 2 & 4 cycle engines
72377906
Type Your Small Engine Question Here...
Donald is online now
A new question is answered every 9 seconds

Have toro ccr 1000. Starts backfiring when warm. Checked for

Customer Question

Have toro ccr 1000. Starts backfiring when warm. Checked for spark, seems weak. Ignition module?
Submitted: 2 months ago.
Category: Small Engine
Expert:  Donald replied 2 months ago.

Hello. Thank you for choosing Just Answer. My name is***** will be happy to assist you.

Expert:  Donald replied 2 months ago.

How long does your engine have to run, before the backfiring began?

Customer: replied 2 months ago.
couple of minutes
Customer: replied 2 months ago.
pretty simple engine. Offered to fix for friend. He said it didn't run at all after storage. I checked the obvious stuff, plug gap. cleaned carb and reassembled. It actually looked pretty clean. Then cranked with new fuel. Took a while to start. Before I fueled it up I pulled plug lead and cranked to check spark. It seemed pretty weak.
Expert:  Donald replied 2 months ago.

Is your engine backfiring through your muffler, or through your carburetor?

Customer: replied 2 months ago.
Thru muffler is afterfire. No it's backfiring through the carb inlet
Expert:  Donald replied 2 months ago.

Thanks for this additional information. It is possible that your intake valve is not properly seating.

Expert:  Donald replied 2 months ago.

Do you know if the engine ran satisfactorily prior to being stored?

Customer: replied 2 months ago.
Well hat makes sense, but i'm looking at the parts diagram and I don't see any valves. It's a two cycle HSk 600 Tecumseh. I am thinking it must be a simple intake/exhaust port system like on a model airplane engine. Am I missing something?
Customer: replied 2 months ago.
It was running fin before storage
Expert:  Donald replied 2 months ago.

Thanks for clarifying that your engine is a two cycle.

Customer: replied 2 months ago.
No, I take that back. My frined said he took it to someone else who charged an arm and a leg for it and it still didn't run. Now, at least it runs, just badly. The oly evidens I could find of any work being done last winter, was what appeared to be a new plug
Expert:  Donald replied 2 months ago.

Can you give me a minute to pull up a diagram for your engine?

Customer: replied 2 months ago.
OK
Expert:  Donald replied 2 months ago.

Thank you for waiting. I am back with you.

Customer: replied 2 months ago.
Any ideas
Expert:  Donald replied 2 months ago.

You said your engine backfires after couple of minutes. Does your engine run smooth up until you reach the two minute mark?

Customer: replied 2 months ago.
Well, not terrifially smooth. I thought is sounded like it was misfiring.
Expert:  Donald replied 2 months ago.

Based upon what we have covered, there are a couple of things I would check.

Customer: replied 2 months ago.
Expert:  Donald replied 2 months ago.

I would check for a partially sheared flywheel key, and focus on your ignition coil.

Customer: replied 2 months ago.
Makes sense to me. We are in agreement. Thank you
Expert:  Donald replied 2 months ago.

You are very welcome!