How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 12592
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
30244710
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

One yr old troy bilt riding mower won't start. Has gas, took

Customer Question

One yr old troy bilt riding mower won't start. Has gas, took battery off and did a slow charge (charged right up). Put battery back on mower and it will no turn over. Just light clicking sound. Red light next to key area is on.
Submitted: 22 days ago.
Category: Small Engine
Expert:  Donald replied 22 days ago.

Hello. Thank you for choosing Just Answer. My name is***** will be happy to assist you.

Expert:  Donald replied 22 days ago.

Can you get the model numbers for your mower for me?

Customer: replied 22 days ago.
Thank you. I am not a mechanic, but am pretty handy. Just frustrated with this mower.
Expert:  Donald replied 22 days ago.

You are very welcome!

Expert:  Donald replied 22 days ago.

I would like to use your model numbers to pull up a diagram of your mower. These numbers are located under your mower seat.

Customer: replied 22 days ago.
13wv78ks011
Expert:  Donald replied 22 days ago.

Thanks for these numbers. Do you have a multimeter?

Customer: replied 22 days ago.
No
Expert:  Donald replied 22 days ago.

Do you know if the clicking sound is coming from your starter solenoid?

Customer: replied 22 days ago.
This is not going to work for me ...sorry. Tks
Expert:  Donald replied 22 days ago.

No problem. The questions I am asking are troubleshooting questions. Your solenoid could be at fault, but it is best to troubleshoot first, just to be sure.