How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 12592
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
30244710
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

My ONAN last started and ran for about 5 min. before it quit

Customer Question

My ONAN last started and ran for about 5 min. before it quit it started hunting for about 30 to 60 sec. Now won't restart.,
JA: Do you have fuel in the tank? If so, is the shut-off valve open and the fuel clean?
Customer: sorry, didn't include Unit info. its' a 7000 watt Onan Marque Model 7NHMFA26105H Propane powered RV unit. I tried Ether in the air cleaner with no results. I suspect the ECM but don't now which electronic device it is. There 2 units that have multiple wires coming out. One in a metal inclosure and one the is black incapsulated. Any advice would be greatly appreciated. Local Cummins/Onan dealer was no help.
JA: Do you plan on doing the work yourself?
Customer: yes
JA: Anything else we should know to help you best?
Customer: no
Submitted: 1 month ago.
Category: Small Engine
Expert:  Hank F. replied 1 month ago.

Hello, my name is ***** ***** I am going to assist you with this.

The first thing I need you to do is to check both plugs to see if you are getting spark.

Are you getting spark to both plugs?

Customer: replied 20 days ago.
History
This propane powered Generator got a little water from a pressure washer 6 months ago. Ran for 30 seconds to a minuet then wouldn't restart start. No fire to plugs. I replaced coil with new but didn't fix the no start problem. Tried starting fluid but no reaction.After being in storage 2 months I brought it home and it started right up, (I had left one plug out and forgotten to put it back but it started up with just the one plug) after replacing the plug it restarted and ran for about a minuet then started hunting (surging) then died. Would not restart, no fire to plugs. I'm thinking ECU/ECM is bad but not sure which of the 2 electronic boxes on the front base of the engine is the ECU.Any other Ideas?
Good source for parts for ONAN?
Tried to use the "Add Files" feature to send a picture of the electrical devices mentioned above but got no response when I clicked on the Add Files on this web page??
Thanks much.
ONAN Marquis 7000
LP fueled
Mdl # 7NHMFA26105H
S.####-##-####***** *****nton
My Phone(###) ###-####
Expert:  Hank F. replied 19 days ago.

There is no ECU on this unit.

If you are not getting spark to the plugs, here is what you need to do:

Disconnect the red and black ignition module wires from the terminals of the coil.
Run a 12V jumper to the red wire of the ignition module. Set your meter to VDC and connect the black meter lead to a good ground.
Connect the red meter lead to the black wire coming from the ignition module.
Using a 3/8" Allen wrench in the rotor through bolt located in the center of the right hand side of the set, slowly turn the engine counter clockwise as viewed from the right end. The meter should read 12V for 1/2 revolution and drop to about 1V for the other half revolution. Turn the motor through at least 3 full revolutions.

What happens?
.

Expert:  Hank F. replied 15 days ago.

Have you been able to do these checks yet?