How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mark Dotson Your Own Question
Mark Dotson
Mark Dotson,
Category: Small Engine
Satisfied Customers: 2
Experience:  Master Service Technician at Mark The Mechanic
96841950
Type Your Small Engine Question Here...
Mark Dotson is online now
A new question is answered every 9 seconds

I have an Onan 4000 in my Motorhome has always run perfect

Customer Question

I have an Onan 4000 in my Motorhome has always run perfect until my last trip. it starts fine and will not shut off or stall out engine just seem to be missing. I replaced the spark plug in the spring when I changed my oil. I just swapped out spark plug no difference. it does flash code 14. I sprayed spark plug wire with some water thinking I might have a crack in the wire I cant see any arcing.
JA: Do you have fuel in the tank? If so, is the shut-off valve open and the fuel clean?
Customer: yes
JA: Do you plan on doing the work yourself?
Customer: yes
JA: Anything else we should know to help you best?
Customer: it is a 2007 it will power the ac unit run all items it always did just has a miss
Submitted: 1 month ago.
Category: Small Engine
Expert:  Mark Dotson replied 1 month ago.

Hello,

It is possible that you may have some water in the fuel. This will cause a miss. Is the generator using the same fuel source as the RV?

Another possibility is that a valve has some carbon building up or the intake and exhaust valves are out of adjustment. Can you inspect those for clearance and do a leak down on the unit?

Another test you can perform is to put a spark tester inline with the spark plug wire and visually see if the spark is breaking down.

Code 14 is an "Over Frequency Fault". This could mean the RPM of the generator is running too fast so check the RPM as well.

Please let me know if you found anything else in your inspection and evaluation.