How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Hank F. Your Own Question
Hank F.
Hank F., Technician
Category: Small Engine
Satisfied Customers: 14630
Experience:  Certified on Onan and Generac generators
19372534
Type Your Small Engine Question Here...
Hank F. is online now
A new question is answered every 9 seconds

I just entered a question about an Onan fuel pump. I tried

Customer Question

I just entered a question about an Onan fuel pump. I tried to make the deposit but was redirected to start over
JA: Do you have fuel in the tank? If so, is the shut-off valve open and the fuel clean?
Customer: Send to technician
JA: Do you plan on doing the work yourself?
Customer: Yes
JA: Anything else we should know to help you best?
Customer: Nope
Onan model 5.5HGJAB-901B. Generator will not start. I traced the issue back to the fuel pump not working. I installed a new fuel pump, pump still does not run. When priming, I confirmed that control board is sending 13.5v but pump does not run. If I jumped the pump directly to the battery it runs and the generator starts and runs fine. I can hear the fuel shut off solenoid engaging when I press the prime button. For the life of me I do not understand why the fuel pump does not run when it is being sent 13.5v and I confirmed that the pump is good. Please advise
Submitted: 5 months ago.
Category: Small Engine
Expert:  Hank F. replied 4 months ago.

When you ran 12V directly to the pump, did you also run a separate ground?

Have you checked the ground wire to make sure it is not broken?

\

Customer: replied 4 months ago.

Yes, I ran a separate ground from the battery. I checked what I could on the ground wire, it appears to be ok. I am guessing that if I placed the volt meter on the positive terminal of the battery and the ground wire from the control box this would check the integrity of the ground?

Also, with the fuel pump connected to the control box, I pushed the prime button and measured 12.5v across the pump. Without the pump attached I was measure 13.5v across the wires from the control box.

Thanks! Roy

Expert:  Hank F. replied 4 months ago.

To check the ground wire, you will need to disconnect the fuel pump, and use an ohmmeter or continuity checker to test from the wire to ground.

Related Small Engine Questions