How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 25661
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

Working on a 5 hp Tecumseh on a Troy-Bilt. It broke a rod, I

This answer was rated:

Working on a 5 hp Tecumseh on a Troy-Bilt chipper. It broke a rod, I rebuilt the motor, put it all back together, and started it up. All good. Ran a minute or so and then it hard stopped when the fan hit the shredder ring. It restarted and then died, would not restart. It seems to have no spark. I check the flywheel key and all the coil grounding wires, all OK. I suspect the solid state coil failed. Suggestions?
JA: Do you have fuel in the tank? If so, is the shut-off valve open and the fuel clean?
Customer: Yup, plenty of clean fuel.
JA: Do you plan on doing the work yourself?
Customer: Yup. If I can.
JA: Anything else we should know to help you best?
Customer: Guess I'm looking for a way to test the coil. Is there a way?

Welcome to JUST ANSWER small engines, let me try to help you !! I don't know it all, but maybe together we can get you a satisfactory answer!

Model number of the engine? Just has single kill wire going to the coil? Remove the kill wire and check for spark, all that makes spark is the coil and the nagnetic in the flywheel.Not likley flywheel magnet fail, but the kill wire to coil may be shorting out the spark If no spark with kill wire removed, this coil is bad.

Customer: replied 13 days ago.
H50. It has two wires to the coil, one to a shut-off, the other to a safety switch. Checked both with a multi-meter, but I didn't actually disconnect them. I'll go try that just to be sure. Flywheel magnets are good and strong. Be right back. Don


Customer: replied 13 days ago.
No hint of spark. I'm turning the motor by hand, but I get a pretty good spin using the chipper fan.
Customer: replied 13 days ago.
I'm going to have to leave for an appointment in a little while. How do we keep the conversation going?

That may not be enough spin to produce the spark!

Customer: replied 12 days ago.
Curtis,Sorry, I had to go off-line today. Question, is there a way to test the coil. I'm pretty sure it is the problem, but it would be nice to prove it. The air gap is OK...0.0125 to 0.130. Anything else I can check? Don

Coil either works r it doesn't, I would remove the kill wire to it, then put the pull start back on enough you can spin the engine. If no spark, coil is bad.

Customer: replied 12 days ago.
Ordered a new coil. Pretty sure that's the problem. Spun it pretty quickly in the dark. Not the faintest hint of a spark. We shall see. Do I close this discussion and rate you now, or leave it open until the problem is solved? Either way, thanks for the help. Don

Either way, you can wait until the new coil comes in. Just log back in from link in your email.

Curtis B. and other Small Engine Specialists are ready to help you

Related Small Engine Questions