How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Wayne Your Own Question
Wayne, Engine Rebuilder
Category: Small Engine
Satisfied Customers: 8258
Experience:  many years on egine rebuilding, lawn mower,roto tiller,Truck,and small engines
Type Your Small Engine Question Here...
Wayne is online now
A new question is answered every 9 seconds

I have a Generac 17KW whole house generator and we are in

Customer Question

I have a Generac 17KW whole house generator and we are in Florida. After dealing with Hurricane Matthew the generator ran for a day and half before shutting down. I now have a error code of overspeed and rpm sensor. Can you help me with this please?
Submitted: 13 days ago.
Category: Small Engine
Expert:  Wayne replied 13 days ago.

Hi I'm Wayne

I will help you with this

the over speed and RPM is the the unit is

not producing full ac voltage under volts

this is normal caused from the gen slip rings dirty or worn

that requires a Tech to split it and replace them

I hope this helped you

Hi. If this helped you,

Please remember to rate my answer 3 or more stars.

I do not get paid for question, unless you rate my answer

If more info is needed, use the reply button -


Customer: replied 13 days ago.
The unit is only three years old. It ran for 1 1/2 days a total of 34 hours. How can the generator need repair already? This generator has never been exposed to the weather and is protected undercover. The generator has only been used a handful of times when we experienced power shortages and now that we really need it, it doesn't work. A amperage test was done and generator output is adequate. Could the rpm sensor cause this problem?
Expert:  Wayne replied 13 days ago.

Thank you for that

I was not aware of all details,

that is why it is important to give a full History of unit

The Fact still remains that it is under voltage

try clearing the codes several times and retry

Customer: replied 13 days ago.
It's not under voltage. Trust me. It runs fine under load for 10 minutes and then speeds up for two seconds and then shuts down with overspeed shutdown alarm. How can I adjust the rpm setting?
Customer: replied 13 days ago.
We are having serious internet and electric problems down here.
Expert:  Wayne replied 13 days ago.

Thank you for that

Yes I trust you , you are there ,I am not

I will opt-out put back to board for another expert

Sorry I could not help you

Do not reply or rate me ,as locks question back to me


Related Small Engine Questions