How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 12172
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

I have a ss5000 2011 4 1/2 tears not a single problem. then

Customer Question

i have a ss5000 2011 4 1/2 tears not a single problem. then ignition switch fell apart. I put in a new one. had to put battery charger on mower to start. the drive brake would not release. I put in a new brake actuator module and still no sound. put in a new battery thinking I had a bad cell because the voltage kept dropping on a 31 month old battery. put it back together and the minute I connected the ground wire to the battery the actuator cycled about 4 times. It started and I got in the seat. the blade will engage no matter what position the handle is in. No sound from the actuator and the brakes are still not releasing.. sum up new switch, new brake control modual, and ne battery....What else?
Submitted: 15 days ago.
Category: Small Engine
Expert:  Curtis B. replied 15 days ago.

Welcome to JUST ANSWER small engines, let me try to help you !! I don't know it all, but maybe together we can get you a satisfactory answer!

Expert:  Curtis B. replied 15 days ago.

I doubt it is problem, but go back and check the terminals on the battery, and be sure the battery has not gotten swapped with positive on the opposite end of the battery and now posiitve terminal on battery is in on the black negative cable.

Customer: replied 14 days ago.
No all terminals are correct. the minute I put the Neg cable back on the brake actuator starts to cycle. you can see a small spark on the battery ( almost as if there is a current draw somewhere) If I did not know better I would say I had gotten a bad new switch. also when I start the machine. and move the control arms in or out, no sound that the actuator is cycling. and yet you can engage the blade electric clutch no matter what position the arms are in (not normal) could it be the arm switches themselves?
Customer: replied 14 days ago.
sorry I am slow getting back to you, I am a city supervisor here and we are in storm prep mode. mostly from rain and high water event. I don't check my personal e-mail but once or twice a day.
Expert:  Curtis B. replied 14 days ago.

Do you have wiring diagram for the mower? I'm thinking there is a relay used to release the parking brake module. If relay is stuck, it would power the brake as soon as the negative cable is attached.

Related Small Engine Questions