How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 26040
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
30244710
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

I have a snapper SPE1250KW. Motor runs fine, no stumbling

Customer Question

I have a snapper SPE1250KW. Motor runs fine, no stumbling then with no warning just stops - almost as if someone turned off the key. It starts right back up. Cleaned carb and fuel seems good.
JA: Do you have fuel in the tank? If so, is the shut-off valve open and the fuel clean?
Customer: yes...and new.
JA: Do you plan on doing the work yourself?
Customer: yes if I can
JA: Anything else we should know to help you best?
Customer: that's about it.
Submitted: 2 months ago.
Category: Small Engine
Expert:  Curtis B. replied 2 months ago.

Welcome to JUST ANSWER small engines, let me try to help you !! I don't know it all, but maybe together we can get you a satisfactory answer!

Expert:  Curtis B. replied 2 months ago.

You have two, OPC switches, one on each side. My thought is one of these switches is cutting off the magneto, as soon as you restart, it is set again. There is no reason the fuel would come and go, so I think you are loosing spark. See the diagram above.

Expert:  Curtis B. replied 2 months ago.

I see question is still open, did you find solution?