How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 27039
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
30244710
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

I have an EZ go that was spuddering and then just quit, I

Customer Question

I have an EZ go that was spuddering and then just quit, I replaced the solenoid, and now the controller but it is still not working. I just found out about the diagnostics and I am getting 4-1 beeps and wondering how to tell if it is the motor or something else
JA: I'll do all I can to help. How long have you been dealing with this?
Customer: It just started....it has been working amazing. After it was sputtering, I held down the gas and it took off and then stopped. The next day it allowed me to pull it in the garage even but now nothing
JA: Do you have fuel in the tank? If so, is the shut-off valve open and the fuel clean?
Customer: No it is electric
JA: Do you plan on doing the work yourself?
Customer: Yes
JA: Anything else we should know to help you best?
Customer: We have tested all batteries and they are good and the cart has a full charge The batteries are only a year old
Submitted: 7 months ago.
Category: Small Engine
Expert:  Curtis B. replied 7 months ago.

Welcome to JUST ANSWER small engines, let me try to help you !! I don't know it all, but maybe together we can get you a satisfactory answer!

Expert:  Curtis B. replied 7 months ago.

Here is the beep code chart, and it shows you have armature open, check connections at the motor and then the motor! Sputtering could have been the motor brushes arching on the armature.

Customer: replied 7 months ago.
Right I know about the beep code charts...I was hoping you could tell me how to fix the issue
Expert:  Curtis B. replied 7 months ago.

Check the connections at the motor, and there is a way to run a test on the motor. Here is link to the motor test, you will have to scroll down the opening page past the manuals to find the troubleshooting guide wih motor test.

Expert:  Curtis B. replied 7 months ago.

I see question is till open, did you run the motor test?