How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 26037
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
30244710
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

Generac wasn't working 2002 15kw liquid. I installed a new

Customer Question

Generac wasn't working 2002 15kw liquid. I installed a new started and solinoid. And battery When I try to start the battery drops from 12 to 6v to 4v board is new.
Submitted: 3 months ago.
Category: Small Engine
Expert:  Curtis B. replied 3 months ago.

Battery is not charged! It should not drop in voltage below 8 volts when cranking. . if it does, it needs to be charged.

Customer: replied 3 months ago.
It has a new battery and is fully charged every time I try to start it. I put a brand-new trickle charger on it.
Expert:  Curtis B. replied 3 months ago.

Only reason battery voltage drops that much is battery low or the cables.

Expert:  Curtis B. replied 3 months ago.

Does engine turn at all when you try to start?

Customer: replied 3 months ago.
I inspected The cables. Cleaned up all the ground terminations. Do you think one of the wires can be damaged and I cannot see it ?
Expert:  Curtis B. replied 3 months ago.

Does engine turn at all?

Customer: replied 3 months ago.
The starter works when I bench tested. It is brand-new unit
Customer: replied 3 months ago.
The starter does not spin or engage when I try starting the unit
Expert:  Curtis B. replied 3 months ago.

Can you turn the engine manually? Engine may be seized!

Customer: replied 3 months ago.
The starter doesn't even Spin out to engage the flywheel. But the flywheel does move freely. The relay and solenoid chatters when trying to start the generator due to the voltage drop that I get.
Customer: replied 3 months ago.
I haven't pulled the spark plugs yet, could anything with the ignition system cause a drop when the solenoid engages? It seems as if something is grounding out it doesn't make sense to me why it would drop
Expert:  Curtis B. replied 3 months ago.

Have the battery tested. I think that is the problem.

Customer: replied 3 months ago.
I just bought it two days ago, do you think I could have received a faulty battery?
Expert:  Curtis B. replied 3 months ago.

Yes! Solenoid chatter is always low voltage.