How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask John Oliver Your Own Question
John Oliver
John Oliver,
Category: Small Engine
Satisfied Customers: 147
Experience:  manager at White Eagle Ag and Truck Services
93794869
Type Your Small Engine Question Here...
John Oliver is online now
A new question is answered every 9 seconds

Installed new oem pto new switch when I pull the switch on

Customer Question

installed new oem pto new switch when I pull the switch on kills the engine
Submitted: 3 months ago.
Category: Small Engine
Expert:  John Oliver replied 3 months ago.

good morning Benny my name is ***** ***** I will be your tech today. sounds like you have a safety circuit that isn't happy and its cutting out the engine? what led you to change the switch?

Customer: replied 3 months ago.
had to install a new pto clutch assy
Customer: replied 3 months ago.
installed new pto clutch assy
Expert:  John Oliver replied 3 months ago.

do you feel like the engine is stalling from a lack of power or its being electrically shut down?

Customer: replied 3 months ago.
as I say when I pull on the pto switch all the power including the amp meter blanks out push switch off mower starts
Expert:  John Oliver replied 3 months ago.

was this issue present before changing the pto parts?

Customer: replied 3 months ago.
no problem mower has 371 hrs still has original spark plugs not ever any problems
Expert:  John Oliver replied 3 months ago.

so what this is telling me is that the ignition circuit is working ok. one of two things is happening.

1) you have a safety circuit that has failed such as the seat switch

2) you have a wire that is loose or burned. you said the amp meter also goes dead so that tells me that when you ask for PTO the amperage that is drawn is to much for your circuit and you loose connection. check on the back of the key switch for a burned or loose wire. any relay contacts and battery, starter connections. feel free to write back with your findings

Expert:  John Oliver replied 3 months ago.

did you have an chance to check any of the things I listed?

Customer: replied 3 months ago.
No electrical problems mower had original belt which had stretched when pto engaged belt would slip off the rear pulley and cause deck to lock up mower is a 2001 model just mowed 1/2 acres no problem after new belt installed
Expert:  John Oliver replied 3 months ago.

so it was mechanical not electrical. good job on the diagnosis.... issues like that make it hard to diagnose behind a computer

have a great weekend!