How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 12592
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
30244710
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

Is it possible for the magnet on the flywheel to get week,

Customer Question

hello sir, is it possible for the magnet on the flywheel to get week, because everything else was done! sanded flywheel, new magneto installed and gapped at .012, new spark plugs, carburetor rebuilt, starter is fine, battery fine, and kill wire and ignition switch fine! will start and run when cold, but when hot after running for a while, it will not start, and i notice there is no spark! changed the module, and same thing again! possibly you have an answer. hope you are having a good day! thank you in advance!
JA: Do you have fuel in the tank? If so, is the shut-off valve open and the fuel clean?
Customer: all that is fine, i am actually a technician, and all ends are covered! it will start and run, but when hot, the magneto will loose spark! i think, that either heat expansion or heat thermal is effecting the transistor magneto, or the magnet on the flywheel is not strong enough when spinning to create enough magnetic field across the magneto for a good spark!
JA: Do you plan on doing the work yourself?
Customer: of course! i went back to the parts place, and got a replacement magneto under warranty, did an ohms test on the new one, and installed it, gapped it at.012, it started, ran, and when it was hot, shut it off, tried to start it, it cranks but does not start, and looses spark! leave it a lone for a few hours, and it will usually start up again,sometimes not! you have to spin that engine quite a lot befor it will start, wich leaves me to believe, that the magnet on the flywheel is going week!
JA: Anything else we should know to help you best?
Customer: all test were done for fuel delivery, ignition,plugs, and wiring!
Submitted: 4 months ago.
Category: Small Engine
Expert:  Briggs-Fan replied 4 months ago.

Hi my name is ***** ***** welcome to Just Answer. Can you give me the make and model of the equipment and the motor ?