How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 12650
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
30244710
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

I have a 2010 ezgo that sometimes will not go forward or

Customer Question

I have a 2010 ezgo that sometimes will not go forward or reverse.It has been put in diagnostic mode and according to chart all 3 beeps refer to solenoid.It had been doing fine for 4 or 5 days.I changed the solenoid anyway and all was good for a week until yesterday and it did the same.Do you all have any suggestions ?
JA: I'll do all I can to help. How long have you been dealing with this?
Customer: I bought it in May and it started this about the middle of June,but it may do fine for several days before it does it again.
JA: Do you have fuel in the tank? If so, is the shut-off valve open and the fuel clean?
Customer: It's electric
JA: Do you plan on doing the work yourself?
Customer: If I can find out the Problem
JA: Anything else we should know to help you best?
Customer: That describes my problem
Submitted: 4 months ago.
Category: Small Engine
Expert:  JON replied 4 months ago.

Sounds like you may have a bad battery or wiring that is causing the solenoid to go out. Check batteries and all wires for breaks, hot spots, and loose connections