How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 12172
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

I have a Brute 2600 PSI pressure washer. The &S engine runs

Customer Question

I have a Brute 2600 PSI pressure washer. The B&S engine runs fine, but I get only nominal pressure from the pressure washer hose. The unit used to cycle (higher and lower RPM) when it was developing pressure, but now only idles. When I manually advance the throttle, it does not develop additional pressure. Any ideas?
Submitted: 3 months ago.
Category: Small Engine
Expert:  JohnF2015 replied 3 months ago.

Hi, my name is***** will be assisting you.

It sounds like the unloader valve inside the pump is stuck or hung and not working properly which will cause this issue.

If you will provide the model, type or spec and serial number I will see if the valve is offered as a replacement part. Sometimes they are not therefore you would have to replace the entire pump assembly in order to fix the issue.

Related Small Engine Questions