How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Hank F. Your Own Question
Hank F.
Hank F., Technician
Category: Small Engine
Satisfied Customers: 14440
Experience:  Certified on Onan and Generac generators
Type Your Small Engine Question Here...
Hank F. is online now
A new question is answered every 9 seconds

Got a Koshin GEH-4000DX Generator With Honda gas engine

Customer Question

Got a Koshin GEH-4000DX Generator With Honda gas engine
Engine runs fine but can't get it to generate any pore
It is a new 2012 unit my neighbor gave me that he never started or tried to use it
I can't fine any info on line for it
Any suggestions?
Submitted: 3 months ago.
Category: Small Engine
Expert:  Hank F. replied 3 months ago.

Try flashing the field.

1. Remove the spark plug wire – you do not want the engine to start while doing this.
2. Obtain an old extension cord that you can cut one end off, or an old power cord from an appliance (you will need the male end left on the cord).
3. This step not needed.
4. Note how on the receptacle, one slot is longer than the other. This longer slot is the negative slot. It is critical that you get it hooked up correctly.
5. Determine which wire of the cord will go to the negative slot.
6. Connect the negative wire to the negative terminal of a 12V battery.
7. Connect the positive wire to the positive terminal of the battery.
8. Plug the cord into the receptacle and pull the starter cord 6-8 times.
9. Immediately unplug the cord. DO NOT LEAVE THE CORD PLUGGED IN FOR MORE THAN 6 OR 8 SECONDS.
10. Disconnect the wires from the battery.
11. Reconnect the spark plug wire and see if the set is now producing electricity.


Expert:  Hank F. replied 3 months ago.

Did you try flashing the field?

Related Small Engine Questions