How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask JON Your Own Question
JON
JON, Small Engine Technician
Category: Small Engine
Satisfied Customers: 533
Experience:  Husqvarna Service Tech
94737911
Type Your Small Engine Question Here...
JON is online now
A new question is answered every 9 seconds

I have a troybilt pressure washer (brand new)....have oil,

Customer Question

I have a troybilt pressure washer (brand new)....have oil, gas, water supply. I start it up and it just runs for 2 seconds and then shuts off
JA: Do you have fuel in the tank? If so, is the shut-off valve open and the fuel clean?
Customer: gas...there is no shut of valve that I can see
JA: Do you plan on doing the work yourself?
Customer: yes
JA: Anything else we should know to help you best?
Customer: no
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Small Engine Technician about your situation and then connect you two.
Submitted: 7 months ago.
Category: Small Engine
Expert:  JON replied 7 months ago.

Is machine like BRAND NEW , this is the 1st time you have started it up? It is sounding like fuel is either shut off (IF EQUIPT) or there is something clogging the carb. What type of engine is on machine.

Customer: replied 7 months ago.
briggs
Customer: replied 7 months ago.
briggs & stratton....no gas shutoff
Expert:  JON replied 7 months ago.

Pull the bowl nut on bottom of carb and clean the all holes on it. It may just have a clogged jet in the bowl nut.

Customer: replied 7 months ago.
no thanks
Customer: replied 7 months ago.
this is wayyyyyy to slow. do you have any answers
Customer: replied 7 months ago.
there is gas coming out of the float bowl when I loosened the bolt holding it on
Expert:  JON replied 7 months ago.

Have you removed the carb bowl nut and checked for obstructions? We can do a phone call if you would like for quicker responses, but they charge more. I usually try to answer all questions on here.

Customer: replied 7 months ago.
ok
Customer: replied 7 months ago.
no live talk
Customer: replied 7 months ago.
It starts & immediately shut off
Expert:  JON replied 7 months ago.

It sounds like it is a carb issue. I would try to pull the bowl nut and clean it out very well. If you have air compressor, blow air through side holes and the top hole. This should correct your problem

Expert:  JON replied 7 months ago.

Is it a prime system or auto choke system?

Customer: replied 7 months ago.
auto choke system. no primer bulb
Expert:  JON replied 7 months ago.

what is the model type off of the valve cover? I will look up engine, so I can view it and its components.

Customer: replied 7 months ago.
i will go and get that information
Expert:  JON replied 7 months ago.

have you attempted to hold trigger down when you start it? Sometimes pressure build up will kill the engine if it has not been ran

Expert:  JON replied 7 months ago.

ok, I will be here.

Expert:  JON replied 7 months ago.

I can give you a little more info once engine info is known, but also check the gov spring and make sure it is not damaged in any way. If it is bent or twisted, it will not let the engine run once started. Most of the time it will not even allow engine to start, but each machine is different in this manner. I would personally start by cleaning the bowl nut (with jets) if equipt.

Customer: replied 7 months ago.
I started the unit up with the trigger held down, as you suggested, and now it is running. One problem....when I let up off of the switch, it immediately dies.
Expert:  JON replied 7 months ago.

so when you stop spraying it is killing the engine? How new is this machine? Is this your first time using it?

Customer: replied 7 months ago.
Brand New. Just bought it today from LOWES. It immediately kills the engine as soon as I let off of the trigger
Customer: replied 7 months ago.
I figured that it would be more than worth the money to ask you than to take it back to the store
Expert:  JON replied 7 months ago.

I hate to say this, but with LOWES you have 30 days to return machine for a refund or swap. I would return this machine as being new and giving problems, you may be in store for more issues even if this one is fixed, and after 30 days they will want to send it off to the warranty dept. for repairs. They should let you do an even swap for another new one.

Customer: replied 7 months ago.
OK......thank you. I will take it back to the store. Thank you for your assistance
Expert:  JON replied 7 months ago.

It sounds like there may be a Governor issue, or REV limiter issue, and that is an internal issue that you do not want to get into. It could be a simple gov. spring , but then again, its a new machine and you shouldn't have to put new parts on a new machine. If it will run under a load, but not idle, the most I would do it clean that bowl nut. if that doesn't repair the issue, take back to store and exchange for a new one

Expert:  JON replied 7 months ago.

No problem. Sorry I wasn't able to help you repair the issue, but it may be more trouble to try to chase this issue since it will run under load but not idle. I hope my services helped some, and you can get the issue resolved by returning to store for an exchange. Please remember to RATE me as I strive to be the BEST and your rating helps me to achieve this. Thank you and have a good evening. Let me know if I can do anything else for you.

Expert:  JON replied 7 months ago.

I hope you got issue resolved.​

Please remember to RATE me as I strive to be the BEST and your ratings help me to achieve this goal!