How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 12172
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

I have an LGT2654 mower with about 300 hours. The mower

Customer Question

I have an LGT2654 mower with about 300 hours. The mower slows down and even stops while mowing uphill. No change in engine RMPs or Slow down in the deck itself. I have replaced the transaxel by a dealer and he also replaced the drive bely. Still having the same problem. Any ideas?
Submitted: 3 months ago.
Category: Small Engine
Expert:  JohnF2015 replied 3 months ago.

Hi, my name is***** will be assisting you.

How old is this machine? When the transaxle was replaced was the replacement a new one or a used one? Did they use original equipment parts or aftermarket parts while completing this repair?

Customer: replied 3 months ago.
this was done through a Husgvarna dealer with new warehouse parts. As i said I have 300 hours on it.
Customer: replied 3 months ago.
are you still there
Expert:  JohnF2015 replied 3 months ago.

How old is the machine? 300 hours for a normal homeowner could mean that the machine is 6 - 7 years old and well outside of warranty. The dealer may have used aftermarket parts in order to save you money on the repair. Or possibly even used parts in the case of the transaxle.

My first thought in this case is that you have a belt slipping, which could be a problem with the belt itself or a tension spring that tightens the belt. If the dealer installed an aftermarket belt it could be that the belt was not an exact match for the original and is already giving you issues.

Related Small Engine Questions