How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 27821
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
30244710
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

When installing the battery on my KIOTI the cables were put

Customer Question

when installing the battery on my KIOTI the cables were put on the wrong posts and sparks flew and cables were correctly installed but, I don't have any current to ignition key although there is power to solonoid on top of starter; did I blow a fuse which needs to be replaced? It is a 36hp.
Thank you.
Submitted: 11 months ago.
Category: Small Engine
Expert:  Curtis B. replied 11 months ago.

Yes, it blew fuse. Do you have manual showing the fuse block?

Customer: replied 11 months ago.
NO
Expert:  Curtis B. replied 11 months ago.

looks to be on the firewall behind engine. see link above.

Expert:  Curtis B. replied 11 months ago.

Sorry link didn't work Let me try again.

Expert:  Curtis B. replied 11 months ago.

This one works!

Customer: replied 11 months ago.
Write your reply here... I do not wish to switch.
Expert:  Curtis B. replied 11 months ago.

Do you see the link I sent above? It shows the fuse box, under hood, on the firewall.

Customer: replied 11 months ago.
Expert:  Curtis B. replied 11 months ago.

OK> if you are done, please rate to close and get me credit.