How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 26054
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
30244710
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

Briggs & Stratton 18hp single magneto, no spark, put new

Customer Question

briggs & Stratton 18hp single magneto , no spark , put new magneto on starts one time only , three new mags , three one time starts
Submitted: 5 months ago.
Category: Small Engine
Expert:  Curtis B. replied 5 months ago.

?? Is there voltage being applied to the coil from the kill wire? Should be no voltage in the kill (black) wire to the coil. It is only there to ground the coil. Have you unplugged the kill wire and checked for spark?

Customer: replied 5 months ago.
No power with the key off or on or in the start position,ground connection with the key off
Customer: replied 5 months ago.
Ground wire off still no spark
Expert:  Curtis B. replied 5 months ago.

did you check for battery voltage on the kill wire?

Customer: replied 5 months ago.
No battery power on the kill wirein the off on or starred position
Customer: replied 5 months ago.
I can put on a new magneto starts right up only one time
Expert:  Curtis B. replied 5 months ago.

Makes no sense! Are you using the Briggs OEM coils?

Customer: replied 5 months ago.
my manual calls for a 492341 and Briggs & Stratton interchange is it the number 591459
Customer: replied 5 months ago.
It's driving me crazy it starts right up immediately with a new magneto each time
Expert:  Curtis B. replied 5 months ago.

would try a new coil and leave the kill wire off it until it has ran awhile. Seems like there has to be an external problem, killing the coils!

Customer: replied 5 months ago.
Checked the ground terminal on the four pole starter silonoid with a light tester and it lights up ? I took a voltmeter from the neg battery post to the Magnito mounting bolt , I get one volt reading?
Expert:  Curtis B. replied 5 months ago.

Four pole solenoid should not be grounded, the small terminals do complete the ground circuit for the start circuit.

Customer: replied 5 months ago.
I don't have a starting problem I have a problem with the magneto going bad , could it be the ground terminal on the solenoid getting power from the large battery terminals if the silonoid was bad , it has two large terminals two small terminals one small journal has a white wire the other small Terneral as two black ground wires to it, I believe they are ground
Expert:  Curtis B. replied 5 months ago.

You didn't give model number for engine. Is this the older opposed twin flat head? I was just answering your statement on the starter solenoid. The black wires are ground wires, the white wire is the wire from keyswitch for start.

Customer: replied 5 months ago.
18 hp electric start , lawnmower , craftsman###-##-####, so the ground terminal on that solenoid if I put a light tester from the ground from the battery to that ground terminal my test light comes on is that possible
Expert:  Curtis B. replied 5 months ago.

ground to ground should not show voltage. Have voltage leak somewhere.

Customer: replied 5 months ago.
The two black wires to that small terminal off light tester light comes on , is it draining through the silonoid
Expert:  Curtis B. replied 5 months ago.

remove the wires and test wires and the solenoid.

Customer: replied 5 months ago.
How do I test the solenoidand , and what I'm I testing the wires for as far as looking for ,
Expert:  Curtis B. replied 5 months ago.

do the same test you were using before, looking for source of voltage.

Customer: replied 5 months ago.
I did take the wires off the ground of the sill annoyed put a light tester there and it lights up does that mean that the solenoid would be bad and allowing voltage to go to the ground on the small terminal of the silonoid
Expert:  Curtis B. replied 5 months ago.

you have light from ground of battery to small terminal of solenoid and it lights? Solenoid has voltage leak, replace the solenoid.

Customer: replied 5 months ago.
Thanks I'll see if that works let you know
Expert:  Curtis B. replied 5 months ago.

OK> Thanks