How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 25631
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

My husqvarna riding mower fun fine but after 20 min. Or so

Customer Question

My husqvarna riding mower fun fine but after 20 min. Or so the blades bog down and tries to kill the engine. If I turn the blades off the mower runs fine.
JA: What's the make and model of the mower? And can you guesstimate how old it is?
Customer: I'm not sure on any of it. I'm not at home. I'm guessing it's about 5 years old
JA: Do you plan on doing the work yourself?
Customer: Yes
JA: Anything else we should know to help you best?
Customer: I just dropped the deck and put on new blades
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Small Engine Technician about your situation and then connect you two.
Submitted: 3 months ago.
Category: Small Engine
Expert:  Curtis B. replied 3 months ago.

Do you have a two cylinder engine? One cylinder may not be firing!

Customer: replied 3 months ago.
It's a twin cylinder
Expert:  Curtis B. replied 3 months ago.

Run a cylinder test. Loosen the spark plug wires, and with engine running at idle, remove one wire at a time, engine should continue to run. If engine dies when one wire is removed, the opposite cylinder is not foring.

Customer: replied 3 months ago.
It kept running
Customer: replied 3 months ago.
The engine itself runs fine. Just after 20 minutes or so when the blades are running it will start to bog down. There are no obstructionsurprises around the belts as well
Expert:  Curtis B. replied 3 months ago.

OK, but did you run the test when engine is bogging down? Or cold?

Customer: replied 3 months ago.
Expert:  Curtis B. replied 3 months ago.

I'm thinking the engine has a weak coil on one cylinder, and is cutting out when hot. You can get a spark tester from auto supply and check the spark without removing wires. easier to test when it acts up.

Customer: replied 3 months ago.
I will try that tomorrow
Expert:  Curtis B. replied 3 months ago.


Expert:  Curtis B. replied 3 months ago.

I see question is still open, did you find problem?

Related Small Engine Questions