How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 26772
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
30244710
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

My Craftman mower is running fine when I start it and when I

Customer Question

My Craftman mower is running fine when I start it and when I engage the blades. When I attempt mow and speed up the blade are very sluggish.
Submitted: 9 months ago.
Category: Small Engine
Expert:  Curtis B. replied 9 months ago.

Model number? With engine OFF, engage the deck and check the belt drive for it, is the belt tight? The deck typically has a tension spring that keeps the belt tight . If belt is loose, the spring may be off or broken, or the belt may need to be replaced.

Customer: replied 9 months ago.
Craftsman###-##-####Belt is tight with engine off with or without blade engaged.
Expert:  Curtis B. replied 9 months ago.

Blade belt drive is direct off the engine crankshaft. Have the blades been replaced? Are they on with the turned up ear up?

Expert:  Curtis B. replied 9 months ago.

I see question is still open. Did you see my response?