How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 26052
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
30244710
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

I have a craftsman lawn mower with a 24hp Platinum V-twin

Customer Question

I have a craftsman lawn mower with a 24hp Platinum V-twin engine model number(###) ###-####5. It used to run fine but now after sitting over the winter with stabil in the gas tank ,when you put a load on it it backfires and revs up and down. There doesn't appear to be much gas in the fuel filter (new) but it still runs. I have replaced the air and fuel filters changed the oil and changed the spark plugs and it is still is having this problem. The engine only has 40 hours on it and seems early to have these sorts of problems
Submitted: 5 months ago.
Category: Small Engine
Expert:  Curtis B. replied 5 months ago.

Do a cylinder balance test. Loosen the spark plug wires, and with engine idling, remove one wire at a time. Engine should continue to run. If engine dies when either wire is removed, the opposite cylinder is not firing. If that is the case, check for spark and compression. If it has spark and compression, and is not firing, check the valve pushrods.

Expert:  Curtis B. replied 5 months ago.

Did you run the test?

Customer: replied 5 months ago.
I haven't had a chance yet going to be gone for the next 2 weeks try then
Expert:  Curtis B. replied 5 months ago.

OK> Thanks!

Customer: replied 5 months ago.
i did the test and the cylinder on the right side is not firing sufficiently to keep the engine running. I have spark and the compression on both cylingers is less than 5 psi different. I checked the rockers and pushrods and both are OK. Seems it must be fuel. I understand it is common for the rubber o rings and gaskets in the carb to degrade and block off one side from fuel. I am contemplating purchasing a carb rebuild kit and rebuilding the carb.
Expert:  Curtis B. replied 5 months ago.

Did you check the valve lash while you had rocker cover off? 004 to .006 inch intake and exhaust.

Customer: replied 5 months ago.
Valve adjustment ok buying carb rebuild kit and fuel pump to see if they are the problem
Expert:  Curtis B. replied 5 months ago.

you may have a bad diode in the kill wire harness between the tow coils! Remove the kill wire from both coils and see if engine run correctly. I don't see this as carb or fuel pump problem.

Customer: replied 4 months ago.
Didn't know where the kill wire or tow coils were so I rebuilt the carb and replaced the fuel pump and it works just fine now!
Expert:  Curtis B. replied 4 months ago.

Good job I guess the two jets in the carburetor were the problem! Thanks for the reply! At least the balvance test got you headed in the right direction! Please rate to close.