How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 26029
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
30244710
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

John deere riding mower l130 kohler engine replaced gas filter,fuel

Customer Question

john deere riding mower l130 kohler engine replaced gas filter,fuel pump,blew out lines still not getting gas to carb.runs as long as starting fluid is sprayed stops when stop spraying.
Submitted: 6 months ago.
Category: Small Engine
Expert:  Curtis B. replied 6 months ago.
http://jdpc.deere.com/pimages/PU04/PU04066________UN21JUL11.gif
Expert:  Curtis B. replied 6 months ago.
Fuel tank has suction tube in top of tank. everything before the fuel pump as to be vacuum tight.
Expert:  Curtis B. replied 6 months ago.
Remove the tube from tank,just slips out of grommet, and vacuum test from thereto the fuel pump inlet.
Customer: replied 6 months ago.
gas gets all the way to new fuel pump but does not come out other side that goes to carb.
Expert:  Curtis B. replied 6 months ago.
Pump is powered by the pulse line P. that gets pulse from the crankcase.Do you have a pulse it the fuel pump P line?
Customer: replied 6 months ago.
dont know.if dont what would be problem
Expert:  Curtis B. replied 6 months ago.
pulse line may be plugged with debris or is loose or cracked.
Customer: replied 6 months ago.
ok pulse line is one of the hoses coming off fuel pump.blew them out checked them.they look ok.what else could it be
Expert:  Curtis B. replied 6 months ago.
Pulse line has to go to the P port, p is not pressure port. Is it in the right spot? Feel the pulse line while cranking, you should feel light pulse pressure.
Expert:  Curtis B. replied 6 months ago.
If fule is not going through the pump, it is not pumping.