How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 12592
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
30244710
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

I have an exmark later z efi won't start has new fuel filter and

Customer Question

I have an exmark later z efi won't start has new fuel filter and fuel pump seems like it's still not getting fuel has spark on both plugs
Submitted: 6 months ago.
Category: Small Engine
Expert:  Curtis B. replied 6 months ago.
http://www.kohlerengines.com/onlinecatalog/pdf/62_690_05_EN.pdf
Expert:  Curtis B. replied 6 months ago.
Service manual link. Way to high tech for me. I will opt out. Sorry.
Expert:  JohnF2015 replied 6 months ago.
Hi, my name is***** will be assisting you.Since you replaced the fuel filter and pump have you purged the air from the fuel lines or fuel system. You may have an air pocket in the fuel rail or lines that is causing your problem. Do you hear the fuel pump cycle on when you turn the key from off to on/run position?
Customer: replied 6 months ago.
I got it fixed myself thank you for getting back to me tho
Expert:  JohnF2015 replied 6 months ago.
Thank you for letting me know.Just curious to know what you did find the problem to be however?
Customer: replied 6 months ago.
Air in fuel rail I purged it and it fired right up
Expert:  JohnF2015 replied 6 months ago.
Okay, Thanks.I was at least right in my suggestion then.