How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 25640
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

I have an Onan P220G on a WoodMizer band mill that won't run.

Customer Question

I have an Onan P220G on a WoodMizer band mill that won't run. Seems to be getting fuel, and I've tried starting fluid. I've worked through everything in the Service Manuel related to the ignition system. Plugs and plug wires were replaced recently. I can see a robust spark on the left plug (as viewed from the flywheel side) and weaker but visible spark on the right plug. The ignition module tests good. Coil is new, and tests just slightly our of spec on the secondary. It tests 3.3 ohms on the primary (spec is 2.9-3.6 ohms), and 20.53 on the secondary (spec is 14.5-19.8 ohms). Any ideas?
JA: I'll do all I can to help. Is there anything else important you think the Small Engine Technician should know?
Customer: Not at this time
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Small Engine Technician about your situation and then connect you two.
Submitted: 5 months ago.
Category: Small Engine
Expert:  Curtis B. replied 5 months ago.
You have spark and fuel. Have you checked the compression? Have you checked the valve lash?
Expert:  Curtis B. replied 5 months ago.
Did you find problem?