How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 26015
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
30244710
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

I have a John Deere x300 mower with a 2cyl. Kawasaki

Customer Question

hello I have a John Deere x300 mower with a 2cyl. Kawasaki motor. The mower died when I pull up pto to engage blades. The main 15 amp fuse was blown. Replaced it. Still only cranked, no start. Pulled plugs, no spark. Replaced ignition control module and it started right up. Ran 25 seconds and died again. No no spark again?? Any ideas?
Submitted: 7 months ago.
Category: Small Engine
Expert:  Curtis B. replied 7 months ago.
If you remove the single wire going to the two ignition coils do you have spark? The coils and the magnet in the flywheel is all that makes the spark on this engine. If you have spark,the kill circuit is shorting out the spark. Does the engine have an oil pressure switch? Near the oil filter? Looking at parts book, I did not find one, but oil switch can kill spark if it does not detect oil pressure.