How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 26059
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
30244710
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

Art. I have a &S 675 series Craftsman, key start, with front

Customer Question

Art. I have a B&S 675 series Craftsman, key start, with front drive. I had the mower stored over winter and now, after cleaning it up, I have no spark. I verified the cable tension and deadman's switch and it is working properly
JA: Thanks. Can you give me any more details about your issue?
Customer: It has not been run for about 18 months, though gas was drained. Spark plug is clean and good. the battery for the key start is dead but am charging it.
JA: OK got it. Last thing — Technicians generally expect a deposit of about $18 to help with your type of question (you only pay if satisfied). Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 8 months ago.
Category: Small Engine
Expert:  Curtis B. replied 8 months ago.

If no spark, locate the coil, next tot he flywheel and remove it. Then check for spark. If no spark with kill wire removed, the coil has failed. If you have spark, the kill circuit is grounding out the spark. Here is link showing how the Briggs ignition works.

Customer: replied 8 months ago.
Curtiss, Thx. I pulled it apart and isolated the kill switch ground and could not get a spark. Per your comments, it would appear that the coil has failed. Not sure what causes that when it sits idle. I did re-gap the coil to the flywheel per the B&S recommendations. Thought might be it, because it looked like it was touching. Didn't make a difference.
I will order the coil tomorrow and see if that does the trick. All for now. The battery is slowly charging, but not enough to turn the motor over yet. Don't think that will have anything to do with anything. Just another issue with sitting idle for 18 months.
I will continue the discussion as soon as the part shows up. Thx Art
Expert:  Curtis B. replied 8 months ago.

OK> the magnet and the coil is all that make the spark. No spark with kill wire off, it has to be coil!

Related Small Engine Questions