How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 26501
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
30244710
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

I have a Predator 7000-8700 gas powered generator that won't

Customer Question

I have a Predator 7000-8700 gas powered generator that won't start after setting with gas in it for just over a year.I'm trying to figure how to take the strainer out so i can remove the gas from the tank.Haven;t been able to so far.
JA: I'll do all I can to help. Is there anything else the Small Engine Technician should be aware of?
Customer: Well, the gas is old and not holding as long as it should.
JA: Our top Small Engine Technician is ready to take your case. Just pay the $5 fully refundable deposit and I'll fill the Small Engine Technician in on everything we've discussed. You can go back and forth with the Small Engine Technician until you're 100% satisfied. We guarantee it.
Submitted: 11 months ago.
Category: Small Engine
Expert:  Curtis B. replied 11 months ago.

Just remove the fuel line from the tank and drain it into container. There is no screen that can be removed. Does the fule drain in full hose flow? If it does, tank is ok, Just replace with new fuel. Next you may want to remove the carburetor float bowl and drain and clean it. To see if engine will run,remove the spark plug, put a teaspoon of fuel direct into the spark plug hole, reinstall the spark plug and see if it will run for a few seconds.

Expert:  Curtis B. replied 11 months ago.

Did you get the unit running?