How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Hank F. Your Own Question
Hank F.
Hank F., Technician
Category: Small Engine
Satisfied Customers: 14486
Experience:  Certified on Onan and Generac generators
19372534
Type Your Small Engine Question Here...
Hank F. is online now
A new question is answered every 9 seconds

R v motor home 2002 with onan gen. gen. has red light on

Customer Question

r v motor home 2002 with onan gen. gen. has red light on start swith and fuel pump is running and battery is showing 12v at switch but will not try to start eng.
Submitted: 8 months ago.
Category: Small Engine
Expert:  Hank F. replied 8 months ago.

Hello, my name is ***** ***** I am going to assist you with this.

Are you saying that the genset will not even crank, or that it will crank but just won't start?

Customer: replied 8 months ago.
IT DOES NOT TRY TO START
Customer: replied 8 months ago.
IT WILL NOT EVEN CRANK OR TRY TO START
Customer: replied 8 months ago.
STILL WAITING FOR RESPONSE ABOUT HOW TO REPAIR ONAN GEN. IN 2002 WINNBAGO MOTOR HOME
IT WILL NOT EVEN TRY TO CRANK AND RED LIGHT ON SWITCH AT GEN. AND FUEL PUMP RUNNING
NEED TO KNOW
Expert:  Hank F. replied 8 months ago.

Sorry for the delay. I work 2 jobs, and help on Just Answer in the evenings.

I had already gone to bed when you replied last night, and I worked a 12-1/2 hour shift today.

IF the fuel pump is running, you have power getting to the controller.

What we need to do now is to check the starter solenoid.

The starter and solenoid are located behind the engine, so that means you will need to take the black cover off the genset. You may need to remove the genset from the coach to do that.

Once you get the cover off, go to the starter solenoid, and test the small wire for 12V while pressing the start button.

Do you have 12V there?

Customer: replied 8 months ago.
WE UNPLUGED THE WIRING HARNESS AND SENT 12V TO THE SOLIENOID AND IT TRIED TO START
AS SOON AS YOU TURN THE HOUSE BATTIERIES ON THE STATIS LIGHT IS ON AS IF GEN. IS ON AND STARTER LIGHT IS ON AND WIL NOT TRY TO START OR CUT OFF
Expert:  Hank F. replied 8 months ago.

You need to do the check I listed. That check was not to see if the starter solenoid works, but to see if you are getting current from the controller to the solenoid.

Customer: replied 8 months ago.
THANK YOU HAVE BEEN REAL BUSY MYSELF.WE FINALLY GOT THE GEN. TO RUN BY UNPLUGGING WIRING HARNESS FROM COACH TO GEN. BUT WE HAVE TO CRANK GEN. OUTSIDE ANY THOUGHT ABOUT WHY WIRING HARNESS WILL LET NOR START GEN.
Expert:  Hank F. replied 8 months ago.

Yup. The wiring harness is either broken, or has a short in it somewhere. It happens more than one would think.

Expert:  Hank F. replied 8 months ago.

Was this what you wanted to know?