How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 13023
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
30244710
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

HDCAA spec A 10kw onan generator. Generator auto started and

Customer Question

HDCAA spec A 10kw onan generator. Generator auto started and auto stopped twice on day 1 of dry camping. Day 2 auto start had a normal fault of "quiet time" until proper time arrived. Tried to auto start and got fault 45. Engine does not crank. Trys to preheat and then gets fault code 45.
All tests performed with a digital ohmmeter as I don't have a VDC megger or a Wheatstone Bridge to test Stator windings.
Shore power disconnected during all tests.
All AC wires disconnected from TB2 during all tests.
TESTS PERFORMED
1. Disconnected positive lead for 10 minutes reconnected to reset control board. No difference.
2. Checked brushes for wear using 1 inch measure to thru holes to top of brush. measured less than 3/4 in
3. Cleaned slip rings, only showed black deposits from brushes.
4. Checked continuity from slip rings to wire lead at top of brushes.
5. Checked to insure J1-3 and J1-13 are fully inserted.
6. Checked continuity between P3-3 to Q1 and P3-6 to
Submitted: 1 year ago.
Category: Small Engine
Customer: replied 1 year ago.
6. Checked continuity between P3-3 to Q1 and P3-6 to Q607. Removed control board and visually inspected, no apparent burns.8. Checked local control switch S1. Switched closes properly across terminals 2 and 3 when holding in start position. Switch closes properly across terminals 1 and 2 when holding in the stop position.9. Disconnected P1 from control board. P1-3 closes properly to P1-5 when local switch S1 is held in start position. P1-4 closes properly to P1-5 when local switch S1 is held in stop position.10. Did not check any of the remote start stop switches. There are three in addition to an auto start.11. Control fuses F1 and F2 (15 amp) both are good.
Customer: replied 1 year ago.
Checked Resistance from slip rings to the wire at the top of each brush. They each measure slightly over 20 ohms. Seems high. Could that indicate bad brushes.
Expert:  Hank F. replied 1 year ago.

Hello, my name is ***** ***** I am going to assist you with this.

Are you saying that the genset is not even cranking before you get the fault code 45 to come up?

If so, does the fault come up on its own, or are you manually pulling the code?

Customer: replied 1 year ago.
it does not crank and it comes up on its own.
Customer: replied 1 year ago.
I live in Phoenix so we are on mountain time
Customer: replied 1 year ago.
I have my phone with me so I will respond quickly now.
Customer: replied 1 year ago.
To be clear, the preheat light flashes, engine does not crank, and the error 45 comes up on its own.
Customer: replied 1 year ago.
I purchased the service manual from Cummins and as s result all the tests I performed above were recomended in the service manual.
Customer: replied 1 year ago.
Since the engine is not even trying to start. I am thinking maybe it is relay K2 that is bad. If not that then possibly the starter solenoid.
Customer: replied 1 year ago.
Unless you have other ideas I will test the relay when the winds stop blowing and it warms up some.