How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask timoto Your Own Question
timoto
timoto, Technician
Category: Small Engine
Satisfied Customers: 1445
Experience:  40+ years experience, Honda silver level tech., Honda power equipment tech
8313095
Type Your Small Engine Question Here...
timoto is online now
A new question is answered every 9 seconds

I'm getting a fast clicking sound when trying to start my

Customer Question

I'm getting a fast clicking sound when trying to start my 6500e. I've charged the battery and when using the electric start I hear that sound. Also I can not even get the generator to give me a rumble when trying with the pull cord.
Submitted: 10 months ago.
Category: Small Engine
Expert:  timoto replied 10 months ago.

The most likely cause of the clicking sound is a bad battery. The battery may show fully charged with respect to voltage but most likely does not have enough reserve capacity under load of the starter to turn the engine. Try removing the battery and take it to the nearest auto parts store and have the battery load tested to determine if it needs replacement.

Customer: replied 10 months ago.
The generac generator model #0059413....
My father in law just bought this generator earlier this year. The battery should be good. As for the machine not even making a rumbling when I try to start it with the pull cord is baffling me more so. Any ideas on that?
Expert:  timoto replied 10 months ago.

The most likely problem is old fuel varnish is clogging the fuel passages inside the carburetor. You can try spraying a brief shot of starting fluid in the air intake. If the engine starts momentarily until it consumes all of the starting fluid then you have confirmed that it is a fuel delivery problem.

Expert:  timoto replied 10 months ago.

Were you able to check out this problem any further and do you need any further assistance?