How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 26040
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
30244710
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

I have a 520 h wheelhorse ive changed every ignition part

Customer Question

I have a 520 h wheelhorse ive changed every ignition part still no spark only when i shut off engine i get a weak spark at my spark tester
Submitted: 1 year ago.
Category: Small Engine
Expert:  Curtis B. replied 1 year ago.

Onan P220G engine? Do you have 12 volts to the positive side of the coil with the key on? Or try a wire direct from the battery posiitve post to the coils positive side.

Expert:  Curtis B. replied 1 year ago.

Is there a condenser at the coil? And has it been replaced?

Expert:  Curtis B. replied 1 year ago.

Wired like this?

Customer: replied 1 year ago.
There was no condenser before wired in
Customer: replied 1 year ago.
Capacitor
Customer: replied 1 year ago.
there is 12 volts on positive side of to -ground on battery
Customer: replied 1 year ago.
Coil positive to - ground of battery there is 12 volts
Customer: replied 1 year ago.
Any ideas
Expert:  Curtis B. replied 1 year ago.

Did you see the coil wiring diagram from manual link? Manual shows condenser, on the ignition wire terminal. And is this the positive side of coil? Orange wire? And have you tried it with a jumper wire to coil?

Customer: replied 1 year ago.
Ignition module red wire goes to positive on coil black wire goes to negative on coil also on positive of coil there is a white wire the orange wire goes to the middle of the voltage regulator
Customer: replied 1 year ago.
The condenser was never in the circuit and it did work all the time before this problem
Expert:  Curtis B. replied 1 year ago.

OK, have you tried a direct jumper from the battery to the coil positive?

Customer: replied 1 year ago.
Just add jumper then leave spark plug wires attached to coil explain
Expert:  Curtis B. replied 1 year ago.

Remove wire from ignition switch terminal , and attach jumper in it's place on the coil. The check for spark or see if it runs.

Customer: replied 1 year ago.
Are you talking about ignition module wire on coil or key ignition switch
Expert:  Curtis B. replied 1 year ago.

At the coil! power to the coil.

Expert:  Curtis B. replied 1 year ago.

I want to eliminate everything but the ignition components.

Customer: replied 1 year ago.
Removed red wire on coil added jumper from positive side of coil to positive side of battery just turns over
Expert:  Curtis B. replied 1 year ago.

No spark?

Expert:  Curtis B. replied 1 year ago.

Try the old coil.

Customer: replied 1 year ago.
I've did a resistance check on the old coil and have bought two new coils both new coils show 3.2 do I need the condenser for it to spark with the new ignition module
Customer: replied 1 year ago.
Old coil showed 2.2 resistance
Expert:  Curtis B. replied 1 year ago.

I have always used condenser, never tried it without.

Customer: replied 1 year ago.
It worked without by adding jumper are we just by passing the safeties
Customer: replied 1 year ago.
Without condenser
Expert:  Curtis B. replied 1 year ago.

Yes, bypassing all the safeties and the ignition switch and wiring.

Customer: replied 1 year ago.
Should I get a condenser and try it doesn't really make any sense could it be a defective ignition module it is the second one I have trod replaced rotor it on goes one way says towards flywheel I'm stumped
Expert:  Curtis B. replied 1 year ago.

With everything bypassed, all you have is the trigger coil and the ignition module/coil. I think I would get a condenser and try it.

Customer: replied 1 year ago.
Ok I'll try that I'll let you know when it comes in
Expert:  Curtis B. replied 1 year ago.

Ok,thanks.

Customer: replied 1 year ago.
Installed new condenser and wires still only get spark when key is turned off
Expert:  Curtis B. replied 1 year ago.

With voltmeter, what is voltage at the coil while cranking? What does it show when you turn key off? As it sparks just as key is turned off.??

Customer: replied 1 year ago.
6 volts and didn't spark on positive and negative of coil
Expert:  Curtis B. replied 1 year ago.

Isn't this a 12 volt system?

Expert:  Curtis B. replied 1 year ago.

Why does coil not have 12 volts to it?

Customer: replied 1 year ago.
Expert:  Curtis B. replied 1 year ago.

Where is voltage lost?

Customer: replied 1 year ago.
The battery probably needs charging I'm guessing
Expert:  Curtis B. replied 1 year ago.

Charge the battery and recheck,it's not going to work on 6 volts.

Customer: replied 1 year ago.
Ok
Expert:  Curtis B. replied 1 year ago.

Let me know.

Customer: replied 1 year ago.
Charged battery get 12 volts with key on when I crank over the engine I get 7 .5 volts
Expert:  Curtis B. replied 1 year ago.

7.5 at coil? Fully charged battery would be over 13 volts.

Customer: replied 1 year ago.
7.5 volt at coil when I turn over
Customer: replied 1 year ago.
Batterie fully charged
Expert:  Curtis B. replied 1 year ago.

Wire coming direct from key switch?

Customer: replied 1 year ago.
Expert:  Curtis B. replied 1 year ago.

Why such a voltage loss?

Customer: replied 1 year ago.
Not sure
Expert:  Curtis B. replied 1 year ago.

Check the same wire at the keyswitch. If it has battery voltage, replace the wire from key to coil.

Customer: replied 1 year ago.
Ok
Expert:  Curtis B. replied 1 year ago.

Let me know.