How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Briggs-Fan Your Own Question
Briggs-Fan
Briggs-Fan, Small Engine Technician
Category: Small Engine
Satisfied Customers: 1229
Experience:  over 15 years experience in small engine repair, multiple certifications
75998144
Type Your Small Engine Question Here...
Briggs-Fan is online now
A new question is answered every 9 seconds

Model 145: Had to jump to start. Ran about 30 min. Then had

Customer Question

Model 145: Had to jump to start. Ran about 30 min. Then had had electric blade switch fail, then lost power. Battery only 1-year old. What type of charging unit is on the tractor. Is this the most likely issue or a short?
Submitted: 1 year ago.
Category: Small Engine
Expert:  Briggs-Fan replied 1 year ago.

Hi my name is ***** ***** welcome to just answer. You can test your charging unit using a multimeter. Take your multimeter and switch it to DC volts 20 . With the tractor off put your red lead to positive on battery and black lead to negative , you will get a volt reading . Then start the rider even if you have to jump it. And check again . If your charging system is working then it should read a volt to two volts higher than not running

Expert:  Briggs-Fan replied 1 year ago.

Check that , if the charging system is working it sounds like your battery has a bad cell . The reason is after jumping it it stayed running until the switch fail which tells me the charging system kept it running . The battery is most likely bad but test that charging system first

Related Small Engine Questions