How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Hank F. Your Own Question
Hank F.
Hank F., Technician
Category: Small Engine
Satisfied Customers: 14531
Experience:  Certified on Onan and Generac generators
19372534
Type Your Small Engine Question Here...
Hank F. is online now
A new question is answered every 9 seconds

I have a 36k generac that was installed less than 6 months

Customer Question

Hello I have a 36k generac that was installed less than 6 months ago and now it won't start and reads rpm sense loss. I've changed the battery and no luck. Could it be the sensor itself that has gone bad
Submitted: 1 year ago.
Category: Small Engine
Expert:  Hank F. replied 1 year ago.

Hello, my name is ***** ***** I am going to assist you with this.

Some gensets get rpm sense from a Magnetic Pickup Unit (sensor), and others get the rpm sense from a feedback off the ignition system.

Yes, it is very possible that the MPU is bad.

But if this unit is only 6 months old, it is still under warranty, and you will void the warrant if you go digging around in there.

You need to contact an authorized Generac repair facility to have his repaired under warranty.

If you need hellp finding a facility, let me know your ZIP code.