How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 12650
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
30244710
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

I have a 2004 ezgo cart with Robin 9hp EH292CE; I 't have

Customer Question

I have a 2004 ezgo cart with Robin 9hp EH292CE; I don't have any spark and I have checked the ignition coil and have power on both wires. I am not real sure how to check the pulser coil but I did put a test light on both wires to see if there was a pulse when starting engine and I had nothing. My question is I'm not sure if the problem is with the pulser coil, the ign. coil or the ignitor.
Submitted: 1 year ago.
Category: Small Engine
Expert:  Curtis B. replied 1 year ago.

Welcome to JUST ANSWER small engines, let me try to help you !! Unplug the pulsar and use meter set on ohms, then crank and watch if the ohms show pulsar to be on and off. If it does, it is good. If no change , replace the pulsar. It does not have voltage to it.