How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 12592
Experience:  have worked on and around most engine models for 35 yrs./Polaris ATV expert
30244710
Type Your Small Engine Question Here...
Curtis B. is online now
A new question is answered every 9 seconds

I have a 7kw kohler in a 38ft boat i recently bought, it has

Customer Question

hi,i have a 7kw kohler in a 38ft boat i recently bought, it has done 380 hrs. i hold up start button from in cabin and it starts instantly and runs. as soon as i release start switch it stops. i had boat surveyed and his mechanic said 99% of the time with these generators that this happens to, it is one of two things, either oil sensor or exhaust sensor. what is your opinion on this. i am in sth east melb and need this repaired. cheers
Submitted: 1 year ago.
Category: Small Engine
Expert:  JohnF2015 replied 1 year ago.

Hi, my name is***** will be assisting you.

I would agree with your mechanic on the oil sensor, it could be an issue which would cause this problem. I have never had an exhaust sensor cause this problem however. I would be looking at the start relay, voltage output from the genset, or the control board on the machine. Typically this problem is caused by either the oil sensor or the start relay.