How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask JohnF2015 Your Own Question
JohnF2015
JohnF2015, Small Engine Technician
Category: Small Engine
Satisfied Customers: 1017
Experience:  Owner/Service Technician at S & J Small Engines
87465640
Type Your Small Engine Question Here...
JohnF2015 is online now
A new question is answered every 9 seconds

I have a zt54. PTO engagas but blows (20amp) fuse. Burned

Customer Question

I have a white zt54. PTO engagas but blows (20amp) fuse. Burned out switch and replaced. Removed clutch and thoroughly decreased and dried. Replaced fuse box and thenworked but blew sout fuse. Went to 30amp. Worked for a few minutes then new switch burned out. Do I need a new clutch or could it be something else?
Submitted: 1 year ago.
Category: Small Engine
Expert:  JohnF2015 replied 1 year ago.

Hi, my name is ***** ***** I am going to be assisting you with your issue.

Expert:  JohnF2015 replied 1 year ago.

Have you checked the wiring for any possible shorts in the wires? If the wires all look good and have no shorts in them then you have a clutch that is drawing too many amps when running and will need to be replaced. This can be caused by wear on the clutch or a bad bearing in the clutch.

Thank you, ***** ***** been a pleasure to assist to.

Please take a moment to rate your experience.